Potentially a bug

Map Plus helps, usage, issues, bug report, downloads...

Potentially a bug

Postby kcrossen » 2017-12-14 18:57

I have imported North Carolina shape files for property boundaries. If I select one polygon, in "User Data", "Select", then click "Style", then "Fill Color...", change "Alpha" to 0%, click "Save", nothing happens to the fill. If I immediately go back to "Style", "Fill Color...", "Alpha" will still be 100%, not changed.
User avatar
kcrossen
★★
 
Posts: 8
Joined: 2017-12-12 19:31

Re: Potentially a bug

Postby Zax » 2017-12-18 2:02

kcrossen wrote:I have imported North Carolina shape files for property boundaries. If I select one polygon, in "User Data", "Select", then click "Style", then "Fill Color...", change "Alpha" to 0%, click "Save", nothing happens to the fill. If I immediately go back to "Style", "Fill Color...", "Alpha" will still be 100%, not changed.


Please notice that styles of features belong to layers could only be modified with its "associated feature class".

After imported a shp layer, there would be two items added, one is the layer itself, the other is a feature class for it. With the feature class, you can manage the styles and attributes (definitions) of the layer. Please go to the detail of the feature class, use the "Add Basic Style" to add fill color to it.

Btw, the "style" button of the User Data is only designed to work for common features which do not belong to any layer.
If you want to use such button to change the style of a layer, you should convert the layer to a common folder first, although it is not suggested especially when there are thousands of features within a layer.
Zax Zeng
Duwei Technology
User avatar
Zax
★★★★★
 
Posts: 1172
Joined: 2011-07-27 0:54


Return to Map Plus - Forums

cron